Brak polskich znaków

PHP to skryptowy język wykonywany po stronie serwera. Forum przeznaczone na pytania dot. programowania obiektowego, wzorców projektowych itp.
Awatar użytkownika
Grzywienka
Posty: 11
Rejestracja: 22 sie 2013, 14:56

Brak polskich znaków

Post autor: Grzywienka » 29 sie 2013, 12:26

Hej, mam taki problem. Gdy próbuję cokolwiek zrobić w php i ma się wyświetlić jakaś treść to nie ma polskich znaków tylko pojawiają się jakieś krzaczki. Wiecie może jak sobie z tym poradzić?

Awatar użytkownika
Fanatyk
Posty: 88
Rejestracja: 21 sie 2013, 13:27

Re: Brak polskich znaków

Post autor: Fanatyk » 29 sie 2013, 13:06

A powiedz mi czy deklarujesz kodowanie strony w ogóle? Jak i również w czym robisz stronę? W notatniku, notepad++ czy też w jakimś innym programie? Bez tego typu danych nie będziemy w stanie za bardzo powiedzieć, gdzie tkwi przyczyna, bo z fusów to jeszcze nikt z nas nie nauczył się wróżyć.

Awatar użytkownika
BlondKate
Posty: 51
Rejestracja: 20 sie 2013, 19:14

Re: Brak polskich znaków

Post autor: BlondKate » 29 sie 2013, 15:20

Jeżeli chodzi o kodowanie stron z polskimi znakami najlepszy jest utf8 czy też może coś innego? Poza tym jeżeli korzystam z include to muszę wszędzie określić kodowanie czy tylko na stronie głównej, gdzie będzie to wyświetlane?

Awatar użytkownika
Grzywienka
Posty: 11
Rejestracja: 22 sie 2013, 14:56

Re: Brak polskich znaków

Post autor: Grzywienka » 29 sie 2013, 15:27

Mam coś takiego w <head>
<META http-equiv=Content-Type content="text/html; charset=utf-8">
Stronę robię w notatniku bo tak podobno jest najłatwiej i dopiero się uczę układania tego wszystkiego.

Awatar użytkownika
Fanatyk
Posty: 88
Rejestracja: 21 sie 2013, 13:27

Re: Brak polskich znaków

Post autor: Fanatyk » 29 sie 2013, 16:46

Problemem przy korzystaniu notatnika jest kodowanie. Dla mnie najlepsze jest korzystanie z notepad++ gdzie standardowo ustawiam kodowanie na utf-8 bez BOM i wszystko działa tak jak należy i polskie znaki pojawiają się bez problemu. Co do kwestii include to jeżeli nie masz polskich znaków w treści includowanej to nie wyświetlą Ci się w stronie głównej choćbyś miała nie wiadomo jakie cuda.

Awatar użytkownika
Grzywienka
Posty: 11
Rejestracja: 22 sie 2013, 14:56

Re: Brak polskich znaków

Post autor: Grzywienka » 29 sie 2013, 17:01

Pobrałam tego notepad++ i spróbowałam zrobić tak jak robisz i co dziwne nawet zaczęło działać. A jak zrobić by we wszystkich wcześniej zrobionych stronach ustawić takie kodowanie? będzie dużo przy tym zachodu?

Awatar użytkownika
Fanatyk
Posty: 88
Rejestracja: 21 sie 2013, 13:27

Re: Brak polskich znaków

Post autor: Fanatyk » 30 sie 2013, 15:43

Musisz każdą stronę po kolei przejechać w notepad++ przestawić kodowanie i pozmieniać krzaczki. Przynajmniej jeszcze uporządkujesz swoje zasoby i kto wie, może coś zaktualizujesz;)

ODPOWIEDZ